Heartbeat Loading Issues

Incident Report for Heartbeat

Resolved

This incident has been resolved.
Posted Jul 11, 2022 - 13:19 EDT

Update

We are continuing to investigate this issue.
Posted Jul 11, 2022 - 13:19 EDT

Investigating

We are currently investigating this issue.
Posted Jul 11, 2022 - 13:16 EDT